VueJS + WebpackSimple no compila SASS

1

Tengo una nueva instalación de VueJs por webpack simple, tratando de configurar SASS a CSS. Los documentos dicen que está listo para el desarrollo, pero el paquete web solo funciona en SCSS, no en SASS. ¿Alguien puede compartir algunos kwnolegde cómo usar lang="sass"?

TAMBIÉN seguí el tutorial en https://vue-loader.vuejs.org/guide/pre-processors.html#sass-vs-scss pero sin resultado

Archivo webpack

    var path = require('path')
var webpack = require('webpack')

module.exports = {
  entry: './src/main.js',
  output: {
    path: path.resolve(__dirname, './dist'),
    publicPath: '/dist/',
    filename: 'build.js'
  },
  module: {
    rules: [
      {
        test: /\.css$/,
        use: ['vue-style-loader', 'css-loader']
      },
      {
        test: /\.scss$/,
        use: ['vue-style-loader', 'css-loader', 'sass-loader']
      },
      {
        test: /\.sass$/,
        use: ['vue-style-loader', 'css-loader', 'sass-loader?indentedSyntax']
      },
      {
        test: /\.vue$/,
        loader: 'vue-loader',
        options: {
          loaders: {
            // Since sass-loader (weirdly) has SCSS as its default parse mode, we map
            // the "scss" and "sass" values for the lang attribute to the right configs here.
            // other preprocessors should work out of the box, no loader config like this necessary.
            scss: ['vue-style-loader', 'css-loader', 'sass-loader'],
            sass: [
              'vue-style-loader',
              'css-loader',
              'sass-loader?indentedSyntax'
            ]
          }
          // other vue-loader options go here
        }
      },
      {
        test: /\.js$/,
        loader: 'babel-loader',
        exclude: /node_modules/
      },
      {
        test: /\.(png|jpg|gif|svg)$/,
        loader: 'file-loader',
        options: {
          name: '[name].[ext]?[hash]'
        }
      }
    ]
  },
  resolve: {
    alias: {
      vue$: 'vue/dist/vue.esm.js'
    },
    extensions: ['*', '.js', '.vue', '.json']
  },
  devServer: {
    historyApiFallback: true,
    noInfo: true,
    overlay: true
  },
  performance: {
    hints: false
  },
  devtool: '#eval-source-map'
}

if (process.env.NODE_ENV === 'production') {
  module.exports.devtool = '#source-map'
  // http://vue-loader.vuejs.org/en/workflow/production.html
  module.exports.plugins = (module.exports.plugins || []).concat([
    new webpack.DefinePlugin({
      'process.env': {
        NODE_ENV: '"production"'
      }
    }),
    new webpack.optimize.UglifyJsPlugin({
      sourceMap: true,
      compress: {
        warnings: false
      }
    }),
    new webpack.LoaderOptionsPlugin({
      minimize: true
    })
  ])
}

Error

No se pudo compilar.

./node_modules/css-loader!./node_modules/vue-loader/lib/style-compiler?{"vue":true,"id":"data-v-04c2046b","scoped":false,"hasInlineConfig " : false}! ./ node_modules / sass-loader / lib / loader.js! ./ node_modules / vue-loader / lib / selector.js? type = styles & index = 0! ./ src / App.vue Módulo no encontrado: Error : No se puede resolver '../img/Group3.png' en 'C: \ Users \ Damian \ Desktop \ Vue \ karuzela \ src' @ ./node_modules/css-loader!./node_modules/vue-loader/lib /style-compiler?{"vue":true,"id":"data-v-04c2046b","scoped":false,"hasInlineConfig":false}!./node_modules/sass-loader/lib/loader.js ! ./ node_modules / vue-loader / lib / selector.js? type = styles & index = 0! ./ src / App.vue 7: 1073-1101 @ ./node_modules/vue-style-loader!./node_modules/css- ¡cargador!./node_modules/vue-loader/lib/style-compiler?{"vue":true,"id":"data-v-04c2046b","scoped":false,"hasInlineConfig":false}!./node_modules/sass -loader / lib / loader.js! ./ node_modules / vue-loader / lib / selector.js? type = styles & index = 0! ./ src / App.vue @ ./src/App.vue @ ./src/main .js @ multi (paquete web) -dev-server / client?http: // localhost: 8080 paquete web / hot / dev-server ./src/main.js

Tratando de trabajar con esta sintaxis

.carousel {
  background: url(../img/Group3.png);
  min-height: 350px;
  background-size: cover;
  background-repeat: no-repeat;
  padding: 0 0 100px 0;
  border-radius: 4px;
  **&__row** {
    max-width: 1300px;
    margin: 0 auto;
    margin-top: -100px;
    text-align: left;
    .slick-track {
      padding: 0 0 70px 0;
    }}
1
  • vue-style-loader no debería estar en las reglas sass. Eso es lo primero.
    atilkan
    1 de julio de 2018 a las 22:40
1

Primero instale el soporte de sass: npm i --save-dev node-sass sass-loader

1
  • por favor, eche un vistazo al error después de la instalación de node-sass y sass-loader
    Exc
    1 de julio de 2018 a las 21:24