¿Cuál es el nombre del paquete de desarrollador o del paquete de tiempo de ejecución de Python en SuSE LES 11 SP1?

0

_ Tuve un problema con la instalación del mod_wsgi. He encontrado la solución como se muestra a continuación (estoy bastante seguro de que esta es la solución a mi problema) en su sitio web. Sin embargo, no sé el nombre del paquete de desarrollador o del paquete de tiempo de ejecución de Python en SuSE LES 11 SP1. ¿Alguien me puede decir? Gracias_ .

Para compilar mod_wsgi a partir del código fuente, debe haber instalado la distribución completa de Python, incluidos los archivos de encabezado. En una distribución de Linux donde los paquetes binarios de Python se dividen en un paquete de tiempo de ejecución y un paquete de desarrollador, el paquete de desarrollador a menudo no se instala de forma predeterminada. Esto significa que faltarán los archivos de encabezado necesarios para compilar mod_wsgi desde el código fuente. Un ejemplo de los mensajes de error que verá si el paquete de desarrollador no está instalado son:

mod_wsgi.c:113:20: error: Python.h: No such file or directory
mod_wsgi.c:114:21: error: compile.h: No such file or directory
mod_wsgi.c:115:18: error: node.h: No such file or directory
mod_wsgi.c:116:20: error: osdefs.h: No such file or directory
mod_wsgi.c:119:2: error: #error Sorry, mod_wsgi requires at least Python 2.3.0.
mod_wsgi.c:123:2: error: #error Sorry, mod_wsgi requires that Python supporting thread.

Para solucionar el problema, instale el paquete de desarrollador para Python correspondiente al paquete de tiempo de ejecución de Python que ha instalado. El nombre del paquete de desarrollador puede variar de una distribución de Linux a otra. Normalmente tiene el mismo nombre que el paquete de tiempo de ejecución de Python con '-dev' agregado al nombre del paquete. Deberá buscar la lista de paquetes disponibles en su sistema de empaquetado para determinar el nombre real del paquete a instalar.

1

Ver:

http://software.opensuse.org/search?q=%22python-dev%22&baseproject=openSUSE%3A11.4&lang=en

Parece que podría llamarse 'python-devel'.

0