ERROR: Al ejecutar la gema... (Gem::Exception) No se pudieron encontrar las gemas ["ffi"] = 1.15.0

¡Estoy atascado en esto y necesito ayuda desesperadamente! Estoy trabajando en Visual Studio Code para crear una aplicación Flutter que use Firebase. Agregué las siguientes dependencias a mi pubspec.yamlarchivo:

firebase_core: ^1.11.0
firebase_analytics: ^9.0.5
firebase_auth: ^3.3.5
cloud_firestore: ^3.1.6

Mi aplicación escribe una sola línea de texto en Firebase y la lee inmediatamente después (solo una aplicación de prueba para ver cómo funcionan las cosas/aprender la API). Ejecuto la aplicación en iOS Simulator y obtengo un montón de resultados en mi consola de depuración, pero el error en la parte inferior dice:

Error output from CocoaPods:
↳
76

Ignoring ffi-1.15.0 because its extensions are not built. Try: gem pristine ffi --version 1.15.0
Error running pod install
Error launching application on iPhone 12 Pro.
Exited (sigterm)

Ejecuté el gem pristine ffi --version 1.15.0comando en la terminal y recibí la advertencia de permisos. Seguí los pasos aquí e instalé Homebrew w/ rbenvy seguí todos esos pasos, así que no necesito ayuda con esa parte.

Corrí brew install cocoapods, gem install bundlery gem install ffi(recomendado aquí ). He estado dando vueltas siguiendo los pasos en innumerables foros diferentes, pero la aplicación sigue sin poder iniciarse y la consola de depuración sigue mostrando:

Ignoring ffi-1.15.0 because its extensions are not built. Try: gem pristine ffi --version 1.15.0

y cuando ejecuto eso en una terminal sigo recibiendo:

ERROR:  While executing gem ... (Gem::Exception)
    Failed to find gems ["ffi"] = 1.15.0
Answer