Obteniendo un error al usar Carthage para un proyecto rápido

En general, uso Pods para la instalación de dependencias, pero recientemente obtuve un proyecto y usó Carthage. Ahora estoy tratando de instalar Cartago usando el siguiente comando y obteniendo un error. (Ya he instalado la configuración de Cartago)

carthage update --platform iOS                  

Después de presionar este comando en la terminal, aparece el siguiente error.

Skipped installing realm-cocoa binary due to the error:
    "Incompatible Swift version - framework was built with 5.0.1 (swiftlang-1001.0.82.4 clang-1001.0.46.5) and the local version is 5.4.2 (swiftlang-1205.0.28.2 clang-1205.0.19.57)."

ingrese la descripción de la imagen aquí

Tengo Xcode Versión 12.5.1 (12E507) y macOS BigSur Versión 11.5.2

Incluso probé con una versión diferente de Mac OS, no quiero cambiar a una versión anterior de Mac OS. Ya intenté cambiar la versión en cartfile para realm.

si alguien puede ayudar, gracias de antemano.

Answer