BUSCARV solo realiza búsquedas parciales aunque [range_lookup] esté establecido en FALSO

Tengo un problema con BUSCARV, solo está haciendo una búsqueda parcial a pesar de que [range_lookup] está establecido en FALSO. los datos son algo como esto:

https://docs.google.com/spreadsheets/d/18fjaq6pQixoAbeLnD0pQwx5K53CW13vlk8KlyaYiLNY/edit?usp=sharing

subí el archivo a las hojas de Google para una mejor comprensión de mi problema.

Estoy buscando el valor exacto de Sheet2 pero vlookup solo realiza búsquedas parciales.

Answer

No estoy seguro de entender completamente tu pregunta. Los primeros dos "N/A" en la Columna C corresponden a las celdas A2 y A4 en la Hoja1. Si tomo esas dos celdas y busco su contenido en Sheet2, no se encuentra la entrada correspondiente. Parece que BUSCARV está buscando elementos que no existen, por lo tanto.

Así que planteé una pregunta a Microsoft y obtuve esta respuesta. Eso sucede porque * se trata como un carácter comodín. Intenta usar esta fórmula

=BUSCARV(SUSTITUIR(A3," ","~ "),Hoja2!A:B,2,0)

Los comodines para BUSCARV se han documentado aquí .